When you try to upgrade or install a plugin you will get the error:

ERROR: There was an error connecting to the server, Please verify the settings are correct.

This means that ftp is not installed on your server. Just follow the tutorial to install ftp here and you will overcome this error. You will then encounter another error which says this:

Downloading update from http://wordpress.org/wordpress-3.3.2-partial-1.zip…

Unpacking the update…

Could not create directory.: /usr/local/nginx/html/mysite.com/public/blog/wp-content/upgrade/wordpress-3.tmp

Installation Failed

This error is solved by the following procedure:

Change the ownership of all files in the html site to the user who is given ftp access (i.e. the user that you created while installing Vsftpd) with this command:

chown -R lion /usr/local/nginx/html

(change lion for the name of the user created and insert the correct folder address).

Now, when you go on to upgrade, it should work flawlessly. If you still get an error just chmod the wordpress core files to 777 and you should be okay.

# cd /usr/local/nginx/html
# chmod -R 777 *

R means that a recursive change will be made.

ERROR: There was an error connecting to the server, Please verify the settings are correct.

3 thoughts on “ERROR: There was an error connecting to the server, Please verify the settings are correct.

Leave a Reply

Your email address will not be published. Required fields are marked *